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Basic Part Manipulation

This section lets you become familiar with a few keyboard functions and with using some
of the basic part manipulation tools in the tool palette.

Lesson 1 - Layers

Open the Osmond document Sample1 in the usual way, either by double clicking it, or if
Osmond is already running, by selecting it with the Open... command in the File menu. A
new window should appear with a simple design as shown below. This design has four
resistors (R1, R2, R3, R4) and two 14 pin DIPs (U10, U11). Some of the pads have
connecting paths, represented as red lines.

The current layer is Layer 1. To go to Layer 2, press the 2 key on the keyboard. Don't hold
down the command key or any other modifier keyÑjust press 2.

As you can see, Layer 2 is similar to Layer 1 but has no connecting paths. This is a four
layer board so you can also go to Layer 3 and Layer 4 by pressing the 3 and 4 keys on the
keyboard. Try this now.

The other way to visit different layers is to use the popup menu button at the bottom left
corner of the window.

The popup menu lets you go to Layer 1 through Layer 4 but also lets you visit the front and
back Silkscreen layers, the front and back Soldermask layers, and the front and back
Auxiliary layers. Try going to different layers with the popup menu.

To continue with the next lesson, return to Layer 1.
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Lesson 2 - Zoom Tool

The tool palette is the group of buttons at the top of the window. Without clicking the
mouse, move the cursor over each of the buttons in the tool palette.

As you move the cursor over each tool, a short description of the function of the tool
appears in the text field just below the tool palette. Some of these descriptions begin with a
single letter in brackets. This indicates that you can select that tool by simply pressing that
letter on the keyboard (no command or other modifier keys needed). As you become a
power user, you will come to appreciate this feature. However, the normal way to select a
tool is to click on the tool button.

Let us begin the tools lesson by clicking on the Zoom View button.

Note that the cursor now looks like a magnifying glass with a plus in the middle:

Try clicking near R1. You will see that the view is magnified and that R1, or whatever
point you clicked, is now centered in the window.

Now hold down the shift or the option key. The cursor now looks like a magnifying
glass with a minus in the middle:

With the shift key held down, click near R4. The view is now de-magnified to its original
size. However, R4, or whatever point you clicked, is now at the center of the window.

You can also use this tool to by clicking and dragging through an area. When you release
the drag, the magnification changes such that the area selected now fills the screen.

Try using this tool repeatedly to achieve very high magnification. With sufficiently high
magnification you will need to use the scroll bars to view different parts of the design.

To continue with the next lesson, go to a magnification that lets you see all the components
at once.
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Lesson 3 - Move Tool

Click on the Move Parts tool.

Click on either the left or right pad of R1 and drag it to a different location. As you drag,
an outline of the part follows the cursor. However, the center of the pad always snaps to
the nearest grid crossing. When you finish dragging, R1 is redrawn at the new location.
Notice that the path connecting R1 with R2 is still connected.

Next, try moving either U10 or U11. Notice that all the paths maintain their connections.

Often when paths are erased and redrawn, a small section of the underlying part outline
may be erased as well. If this happens enough times, the view will begin to look untidy.
You can refresh the view by simply pressing the R key on the keyboard.

If you move a part and then change your mind, you can undo the operation by selecting the
Undo command in the Edit menu. Nearly all tool operations can be undone in this way.

In this first example, the grid is set initially to 50 mil spacing and all pads are at grid
crossings. If needed, we can modify the grid to achieve more flexible positioning.

The pads for the resistors are 62 mils in diameter. What if we wanted to put the resistors as
close together as possible but still leave 15 mils clearance between the pads. This would
require that the distance from the center of one pad to the center of the next pad be 77 mils.
Let us make it so.

In the Grid menu, select the Custom... command. This will bring up the grid dialog like
this:

Uncheck the Equal X and Y Spacing button and change the Y spacing to 77 mils. The
dialog should now look like this:
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Now move all the resistors so that they are close together and all on grid crossings. The
result should look something like this:

For the next lesson, return to an Equal X and Y spacing of 50 mils. Notice that the resistor
pads are now off grid.
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Lesson 4 - Select Tool

Click on the Select Parts tool.

This tool lets you select one or more components. Try selecting R1 by clicking inside one
of its pads. The result should look like this:

Notice that selected parts have their outlines dashed and their pads grayed. Add R2 to the
selection by holding the shift key and clicking inside one of R2's pads.

To unselect all parts, click anywhere outside of all pads.

Try selecting all the resistors by clicking above all their pads and dragging the selection
rectangle so that it contains at least one pad from each resistor. When you release the drag,
all resistors should be selected like this:

Go back up to the tool palette and select the Move Parts tool that you used in the previous
lesson. Now use the tool to try to move one of the resistors. You will notice that all the
selected resistors now move as a group.

To continue to the next lesson, use the Select Parts tool to unselect all parts by clicking
anywhere on the board, outside of any pad.
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Lesson 5 - Turn Tool

Click on the Turn Parts tool.

Notice that the cursor now looks like this to indicate a counter-clockwise direction
of rotation.

If you hold down the shift key, the cursor changes to this to indicate a clockwise
direction of rotation.

To rotate a part, click on one of the pads belonging to the part. The part rotates 90 degrees
about the clicked pad in the direction indicated by the cursor.

Try rotating some of the parts both clockwise and counter-clockwise by clicking various
pads. Notice that the pad you click is always the center of the rotation and that connecting
paths remain connected.

Sometime you may need to rotate a part by an angle other than 90 degrees. To do this,
double-click on the Turn Parts tool in the tool palette to bring up the following dialog:

Try changing the 90 Degree turn angle to 30 degrees (for example) and experiment with
rotating parts by the smaller angle.

Note that oval and rectangular pads can be rotated only in multiples of 90 degrees.
Therefore, you should use rotation angles smaller than 90 degrees only with parts that have
all circular pads.

Using the Select Parts tool that you used in the previous lesson, select all the resistors.
Now using the Turn Parts tool, try to rotate one of the resistors. Notice that all the
selected resistors rotate as a group.
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Lesson 6 - Flip Tool

Click on the Flip Parts tool.

Parts can either be on the front side of the board or on the back side of the board. Use this
tool to flip parts from one side of the board to the other.

Try flipping one of the parts in the design by clicking on its pad. Notice that the color of
the part outline changes and that connecting paths remain connected. If connecting paths
being erased and redrawn cause the view to look untidy, refresh the view by pressing R.

The Osmond program will always keep connecting paths connected when flipping parts.
For this reason it will not be possible to flip surface mount parts if they already have
connecting paths.

This concludes the chapter on manipulating parts. Close the view without saving the
design. We will look at a slightly different design in the next chapter.
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Path Manipulation

This section lets you become familiar with tools for manipulating paths. a few keyboard
functions, and with using some of the basic part manipulation tools in the tool palette.

Lesson 1 - Connecting Paths

Open the Osmond document Sample2 in the usual way. This design contains four resistors
and two dual inline packages but has no connecting paths, as shown below.

Because this design has a net list, the Osmond program knows what pins should be
connected to what other pins. One way for you to see what pins need to be connected is to
press the N key on the keyboard (N is for Next). The view should look like this:
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The two pins in color are the two pins that should be connected. Notice that the signal
name (**Signal 1**) appears in the text area just below the tool palette.

To see the next set of pins that should be connected, press the N key again. Continue
pressing the N key to cycle through all the signals that still need to be connected. To cycle
through the signals in the reverse direction, press the V key on the keyboard (V is for
preVious).

If you press the N or V keys continually and no pins are highlighted, this means that all the
pins have been connected.

From the tool palette, select the Choose/Connect tool.

Click on any of the resistor pins. The pin that you click on changes color to cyan. Other
pins that still need to be connected to this pin change color to magenta. If the pin you click
on remains un-colored, then this pin should have no connection to any other pin.

Now let us connect some pins. Click on the left pin of R4 (cyan) and drag toward the right
pin of R3 (magenta). As you approach R3, a ghost line appears to indicate that this
connection is allowable. When you release the drag, a new path is created.

Now click on the right pin of R4. Notice that you can connect this pin to any of three other
pins. Click on the right pin of R4 and drag toward any of the three magenta colored pins.
As you near the pin, a ghost line appears to indicate that the connection is allowed. Repeat
the use of this tool until all four pins are connected.

From the tool palette, select the Cut Path tool.

Use this tool to delete one of tha paths you created by clicking on the path.

Experiment with connecting paths and cutting paths.

For the next lesson, connect all the pins so the design looks like this:
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Lesson 2 - Moving Paths

From the previous lesson we have a design in which all the pins are connected. However,
some of the paths cross and other paths get too close to some pins. The paths need to be
adjusted or re-routed to fix these problems. In this lesson, we will examine several tools
that we can use to re-route paths.

From the tool palette, select the Drag/Remove Pegs tool.

We can use this tool to stretch paths like a rubber band.

Use this tool to stretch the path from R1 to R4 in three steps as follows.

This is like stretching a rubber band around pegs in a peg board. Notice that a small mark
appears on the peg nearest the cursor.

If you click directly on an existing peg, you can drag that peg and the associated path to a
new location. If you click on the path between pegs, a new peg is created. The peg always
snaps to the nearest grid crossing point.

To remove a peg, hold down the shift key while clicking on a peg.

Practice adding, dragging, and removing pegs until you feel comfortable with this tool.

For the next lesson, remove all the pegs you have added.
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Lesson 3 - Wrapping Paths

Using just the Drag Pegs tool from the previous lesson, it is possible to completely route a
PC board. However, that tool only adds pegs at grid crossings and pays no regard to any
spacing requirements. We will now examine a more powerful tool that we can also use to
route paths.

From the tool palette, select the Wrap Paths tool.

Click and drag the path from R1 to R4 upward and to the left over the left pad of R4 like
this:

The tool ensures that there is adequate spacing between the path and the pad. To finish
routing this path, click and drag the path to the left of the left hand pad of R2 like this:

From the tool palette, select the Move Parts tool. Use this tool to move R4 up one grid
interval like this:
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Notice that the path that was "wrapped" around the left pad of R4 is still wrapped even
though R4 was moved.

Reselect the Wrap Path tool from the tool palette.

You can usually unwrap a "wrapped" path by clicking on the path near the wrap and
dragging in the opposite direction. Try this with the section of path around the left pad of
R4. If you do this correctly, you will see this:

Another way to unwrap a path is to simply remove the pegs one at a time using the
Drag/Remove Pegs tool that we learned about in the previous lesson.

Practice wrapping and unwrapping paths around various pads until you are comfortable
with this tool.

For the next lesson, remove all the pegs that you have added.
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Lesson 4 - Automatic and Semi-Automatic Routing

From the Design menu, select the Check Current Layer command. This command
checks the current layer for conflicts caused by crossing paths or inadequate spacing.
When it finds a conflict, it puts up the following floating dialog and highlights the conflict
as shown.

Click on the Yes button. The program now proposes a solution to this conflict for your
approval.
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Click on the No button. The program now proposes a different solution to this conflict.

Click on the Yes button. The program implements the solution and finds the next conflict.
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You can continue in this manner, finding and resolving conflicts one at a time, until the
board is completely routed. Because this design is so simple, however, we can let the
program do more of the work.

Click on the Auto button. This tells the program to find and resolve all conflicts
automatically, without user input, using its own simple heuristics to decide between
alternate solutions. This produces the finished product below:

The Auto button should be used with caution. The heuristics that the program uses to
decide between alternate solutions are very simple minded and may not jibe with good
judgment. Also, it is possible for the program to fall into an infinite loop if the solution to
conflict A creates conflict B and the solution to conflict B brings us back to conflict A. If
the program appears to be waffling between two solutions, you should break out of Auto
mode by pressing any key on the keyboard.

Since we will be working with this same file in the next chapter, you should close the
design without saving.
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Using a Rats Nest

This section lets you become familiar with the Rats Nest feature and with how to use some
of the tools in the Tool Box with the Rats Nest paths.

Lesson 1 - Making a Rats Nest

Open the Osmond document Sample2 in the usual way to reveal the setup as shown below.
As you saw in the previous chapter, this design contains four resistors and two dual inline
packages but has no connecting paths.

In the previous chapter you used the Choose/Connect tool to show what pins should be
connected, and to connect paths between these pins. This tool can also make a Rats Nest.

From the tool palette, select the Choose/Connect tool.

Using this tool, click on the left pin of R1. You should see something like this.
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The pins in color all belong to the same signal and should be connected.

Now, using the same tool, click on the left pin of R1 while holding down the option key.
You should see something like this.

The pins have all been connected by paths on a special layer called the Rats Nest layer.
Later you will see how to convert these to paths on real layers.

Similarly, click on the left pin of R4 while holding down the option key to produce this.
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By continuing in this fashion, you can eventually produce Rats Nest paths for every signal
in your design. However, there is an easier way:

In the Design menu, click on the Make Rats Nest menu item. This makes a rats nest for
every signal in your design as shown below.

In the Design menu, the Destroy Rats Nest menu item eliminates every path connecting
every signal in the Rats Nest layer.

You can also use the Make One Rats Nest menu item to make a rats nest only for the
currently selected signal, and you can use the Destroy One Rats Nest menu item to
eliminate all rats nest paths from the currently selected signal.

What if a signal has many rats net paths and you want to eliminate only one or two? In this
case you can use the normal Cut Path tool.
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Note: The Cut Path tool can be used to eliminate paths on the Rats Nest layer even if the
Rats Nest layer is not the current layer.

Practice making and destroying Rats Nest paths until you are comfortable with the
process. For the next lesson, however, leave all rats nest paths in place as shown above.
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Lesson 2 - Using Tools with a Rats Nest

Now that we have a Rats Nest, what do we do with it?

Lets start with the simplest tool.

From the tool palette, select the Drag/Remove Pegs tool.

When you click on a Rats Nest path with this tool, the path is first automatically
transferred from the Rats Nest layer to the current layer, at which time the tool's usual
function starts working.

Practice using this tool on several of the Rats Nest paths. Using it on two paths, I get the
following:

To try out another tool, let us first restore the design to the state in which all signals are
connected by Rats Nest paths. We can do this by cutting (with the Cut Path tool) all paths
we have modified, and then by clicking the Make Rats Nest menu item in the Design
menu.

From the tool palette, select the Wrap Paths tool.

This tool is similar to the previous tool in the way it works with Rats Nest paths. When
you click on a Rats Nest path with this tool, the path is first automatically transferred from
the Rats Nest layer to the current layer, at which time the tool's usual function starts
working.
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Practice using this tool on several of the Rats Nest paths. When I try it, I get something
like this:

Notice that for straight paths that do not require routing, just clicking on the path is all that
is required to place it on the current layer.

To try out our last tool, again restore the design to the state in which all signals are
connected by Rats Nest paths.

From the tool palette, select the Quick Route tool.

You will notice that a floating window appears containing bend options as shown below.
You should move this window to a convenient location.

For now, we will stick with the default option.

Again, this tool is similar to the others in the way it works with Rats Nest paths. Clicking
on a path with this tool first transfers the path to the current layer, at which time the tool's
normal function starts working.

This tool is different from the other tools in that several mouse clicks are required to
complete one operation. The first mouse click selects a path and identifies the pin nearest
the click point as the starting pin. The pin at the other end of the path then becomes the end
pin.

The original path is erased and a solid line extends from the starting pin to the cursor
position. A dotted line extends from the cursor position to the end pin. The solid line
shows where a new path segment will be drawn when you next click the mouse. When you
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do click the mouse, the new path segment is drawn using the color of the current layer, and
a new solid line is drawn from the end of that segment to the current cursor position. In this
way you define the route of the path by a series of clicks. To complete the operation, click
on the end pin. If you wish to abort the operation, click on the starting pin or select a
different tool from the tool palette.

Practice using this tool on several of the Rats Nest paths. When I try it, I get something
like this:

Note that you can also use this tool on paths that are not Rats Nest paths. When you do
this, you can modify the path segment that you click on. If you hold down the option key,
the entire path is first erased.

The other bend options allow you to place constraints on how the path is routed.

This option, for example, requires paths to first extend in a vertical or horizontal direction
followed by a diagonal direction where the angle of the diagonal is 45 degrees.

Practice using the tool with this option on paths in your design, even on paths already on
the current layer. When I try it, I can get something like this:
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The other bend options are similar. The third option requires paths to extend first in a
diagonal direction followed by a horizontal or vertical direction.

The fourth option requires paths to extend first in a horizontal direction followed by a
vertical direction while the fifth option requires paths to extend first in a vertical direction
followed by a horizontal direction.

Practice with these various options until you are comfortable with their use.

The sixth option lets you sample the pattern of bends from an existing trace so you can
then apply that same pattern to other traces. Of course, this works only if the spacing of
end points of the new trace matches the spacing of end points in the sampled trace.
However, one often finds this situation in practice, especially when routing bus signals.

To see this in action, let us start with a fresh rats nest as shown below.

Using one of the normal bend options, route the first long trace between U10 and U11 as
shown.
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Now, select the sample pattern option as shown below.

Now sample the pattern of the trace you routed by clicking on the trace while holding
down the shift key. You will notice that the cursor changes to a dropper while the shift key
is depressed. Release the shift key when you are done.

Now click on the other long traces between U10 and U11. You should get something like
this.

If you click on any of the shorter traces nothing happens since the spacing of the end points
of the shorter traces do not match the spacing of the end points of the sampled trace.
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In Conclusion

As you can see, routing can be accomplished using a variety of tools and options. Feel free
to use whichever methods works best for you.
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Starting a New Design

In this chapter we go through the process of creating a new design.

Background

To begin a new design, you should usually have three input files:
* Parts Library
* Parts List
* Net List

The Parts Library contains descriptions of every part type that you plan to use in your
design. The format of the descriptions in the Parts Library is documented in the Osmond
Reference Manual. The tutorial folder has an example Parts Library file (named Library)
that you can examine at your leisure with an ordinary text editor.

The Parts List contains a list of every part in your design, including the part name and the
part type. Each part should have a corresponding part type description in the Parts
Library. The tutorial folder has an example Parts List (named PartList2) that looks like
this:

Part RCR05 { Name R1 }
Part RCR05 { Name R2 }
Part RCR05 { Name R3 }
Part RCR05 { Name R4 }
Part DIP14 { Name U10 }
Part DIP14 { Name U11 }

Here we are dealing with a very simple design that contains just six parts: four resistors
and two dual-inline packages. The words "Part" and "Name" are keywords. The part types
used in this example are RCR05 and DIP14. The part names used are R1, R2, R3, R4, U10,
and U11.

The Net List contains a list of all the signals in the design and what pins connect to each
signal. The tutorial folder has an example Net List file (named NetList2) that looks like
this:

Signal "Signal 1"
  { R2-1 R1-2 }
Signal "Signal 2"
  { R3-1 R2-2 }
Signal "Signal 3"
  { R4-1 R3-2 }
Signal "Signal 4"
  { U11-14 U10-2 }
Signal "Signal 5"
  { U11-13 U10-3 }
Signal "Signal 6"
  { U11-12 U10-4 }
Signal "Signal 7"
  { U11-11 U10-5 }
Signal "Signal 8"
  { U11-10 U10-6 }
Signal "Signal 9"
  { U11-9 U10-7 }
Signal "Signal 10"
  { U10-14 R4-2 U11-1 R1-1 }

The word "Signal" is a keyword followed by the name of the signal in quotes, followed by
a list of pins that belong to this signal. Each pin is specified by a part name and pin name
separated by a dash. Each part name should have a corresponding part in the Parts List.
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Setup

With the Osmond application running, select the New command from the File Menu. This
brings up a new window as well as the Design Options dialog shown below.

Since we have such a small design, change the Horizontal and Vertical Panel Size to 2.0
inches. Also, change the Default Spacing for both the Outer Layer and the Inner Layer to
15 mils. Notice that the outline of the new panel size is visible in the main view.

Using the Zoom View tool, magnify the view until the panel more than fills up the view.

Select the 50 mil command from the Grid menu to give us finer resolution.

Input

Now we need to read the input files. The first file we must read is the Parts Library.

Select the Import->Library... command from the File menu. Using the finder dialog,
select the file named: Library from the tutorial folder.

Next we need to read the Parts List.

Next select the Import->Part List... command from the File menu. Using the finder,
select the file named: PartList2 from the tutorial folder.

Finally, we need to read the Net List.

Select the Import->Net List... command from the File menu. Using the finder, select the
file named: NetList2 from the tutorial folder.
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Placement

From the Window menu, select the Deferred Parts command. This brings up a floating
window containing a list of all the parts that have not yet been placed on the board. In our
case this is all six parts. To place a part, click on the part in the part list and drag it to a
location on the board. As you are dragging, a rectangular outline of the part appears to
assist you in positioning the part. Do this for each part until you have all the parts on the
board. One possible final arrangement looks like this:

Once the Deferred Parts window is empty it can be safely closed. You can now proceed
to connect all the pins and route all the paths using the methods learned in the earlier
chapters.

Modifying the Design

Designs often need to be modified even after the net list is complete. If you change the net
list file and import it again, Osmond tries to make the design consistent with the new net
list, even if it has to remove paths in the process. If you would rather not modify the net list
(or if you donÕt have a net list at all), you can use Osmond tools to make changes or
additions to the design directly.

Normally, the Choose/Connect Pins tool can connect pins only if they belong to the same
net as defined in the net list.

However, if you hold down the Cmd key, you can connect any two pins by clicking on one
pin and dragging to the other. This forces a connection between the two pins and makes
both pins part of the same net. If neither pin belonged to a net before they were connected,
a new net is created. If both pins belonged to different nets before they were connected, the
two nets are merged into a single net.

It is possible to use this technique to define and construct all the connections of a design
even without a separate net list file. For small to medium sized designs, the may be a
viable option.
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Normally, the Cut Path tool will remove a path between two pins, but the two pins still
belong to the same net.

However, if you hold down the Cmd key while clicking on a path, the path is removed and
the two pins are partitioned into two separate nets. One net contains the first pin along with
everything connected to it, and the second net contains the second pin along with
everything connected to it.

Experiment with using these tools to modify our example design by adding and removing
connections.
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Building New Part Types

In this chapter we go through the process of building a new part type. We will build a
simple imaginary part that will look like this:

Setup

Bring up the Osmond application if it not already running. Create a new design with the
New command or open an existing design using the Open command.

Now issue the Make New Part Type... command from the Parts menu. A dialog appears
that allows you to name the new part type and to specify the height of the text to be used in
the name field. Let us make a part type named JOE6 that has a name field height of 50 mils
by entering the following in the dialog:
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Clicking OK allows the Edit Window to appear with the origin set in the middle like the
picture below. The grid origin becomes the origin of the part type as well. (Note: This
picture was shrunk a little to allow it to fit in this document.)

The edit window has a special subset of tools that are all that is required to build a new part
type.
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Use the Zoom tool to adjust the magnification until you can see the name field at the
origin.

Make sure that the grid spacing is 100 mils by selecting the 100 Mil item in the Grid
menu.

Making Pins

Double click on the New Pin tool in the tool palette to bring up the following dialog. The
pins for our new part will be Regular Thru-hole pins which means they have circular pads
65 mils wide on all layers. Adjust the width and height fields in the Connected Pad area to
65 mils. Also, change the Hole Size to 15 mils. When we are done, the dialog should look
like this:
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Using the newly configured New Pin tool, create a pattern of pins by clicking six times to
produce the pattern shown below. If the pattern is not quite right, you can move the
individual pins with the Move tool.
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Making the Silkscreen

We will use the Draw tool to draw a silkscreen pattern around the pins on the silkscreen
layer. Double click on the Draw tool in the tool palette to bring up the the dialog shown
below. Change the draw option to Rectangle and the width to 5 mils as shown and press
OK.

Now change the grid spacing to 25 mils using the Grid menu.

Change the current layer to the Front Silk layer using the pop-op menu at the lower left
corner of the window.

Now use the Draw tool to draw a rectangle around the pins so that it looks more or less
like the following. The rectangle is created by clicking at one corner and dragging to the
opposite corner. If you need to adjust the position of any of the line segments, you can do
so with the Drag/Remove Pegs tool by clicking and dragging the endpoints of the
segments.
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When the silkscreen rectangle is finished, go back to the Front Layer.

Adjusting the Name Field

Well, the part name field is not really where we would like it, so we should move it. Click
on the Move Parts tool in the tool palette.

Use this tool to move the part name so that it looks like this:
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The part type is now complete. Click the OK button to dismiss the Edit Window and to
place the new part type in the current library.

Using the New Part Type

Now that the JOE6 part type has been created, you can create instances of this part type
like any other part.

Click on the New Part tool.

This makes the Library Parts window visible as shown below. You can click on the JOE6
item in the part list to see the part in the preview window.
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Now clicking anywhere in the design area creates a new JOE6 part and places it at the
click point. After two such clicks, you could see something like this:

Notice that the part numbers are incremented automatically.



Page 40 J C Chavez / jchavez@swcp.com / Osmond Tutorial

Making a Part Library

You can repeat the process to create other parts for your library. Once you have created
parts and saved your design, you have also created a library. There is really no difference
between a Library File and a Design File. Often, a Library file contains only part types
and does not have any concrete instances of any part. However, this is not necessary. You
can if you wish, use an existing Design file, containing part types, concrete parts, paths,
etc., as a library for a new design.

All that you need to do is to Open the Library in a separate window. Then using the
Library Parts window that you view via the Window menu, you can access any part type
from any open design to create instances in your new design.
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